Konfiguracja routera Cisco z adresem WAN z dhcp i adresami dla klientów z dhcp

Przykład jak skonfigurować router Cisco aby pobierał na interfejsie WAN adres IP z DHCP i rozdawał IP ze swojego DHCP.

Linie 1-6 to pula dhcp dla klientów z LANu, opcja import all importuje wszystkie potrzebne ustawienia uzyskane z serwera dhcp po stronie WAN do ustawien serwera dhcp po stronie LAN np. DNS.
Linie 16 i 23 to  ustawienia interfejsu WAN czyli pobieranie adresu z serwera dhcp i ustawienia domyślnego routingu.

!
ip dhcp pool vlan1pool
   import all
   default-router 192.168.1.1
   network 192.168.1.0 255.255.255.0
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
 ip address dhcp
 ip nat outside
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
!
ip route 0.0.0.0 0.0.0.0 FastEthernet4 dhcp
!
ip nat inside source route-map my_rmap1 interface FastEthernet4 overload
!
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
!
route-map my_rmap1 permit 1
 match ip address 101
!

 

Share Button

Przemek

Twórca portalu techfreak, elektronik, pasjonat wszystkiego co fajnie, co można przerobić. W wolnym czasie grzebie przy nettemp. A sport jaki uprawia to mini drony klasy 250.

  • Robert

    Mam pytanie jak skonfigurować router tak aby posiadał adres WAN z innej sieci LAN z dostępem do internetu a jednocześnie mógł komunikować się z tą siecią LOKALNĄ za WAN pomijając NATOWANIE (które dodatkowo obciąża procesor routera) ??

    • Przyjmując ze masz na np na WAN ip 192.168.0.1 i gw 192.168.0.2 z maska 30 a LAN w 10.0.0.0/24 musisz zamienić maskę wan na szerszą np 24. Podaj konfiguracje to się zobaczy :)

  • Arkadiusz

    Nie zapomnijmy także o włączeniu poszczególonych interfejsów poleceniem „no shutdown”.
    Pozdrawiam Arek :)

  • chuj

    pierdole was

    • cipa

      sam sie pierdol